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PERTEMUAN I 

 

Pengenalan Flash 

 

1. 1. Konsep Dasar dan Istilah 

 

Stage 

Stage pada Flash terlihat berupa kotak putih besar yang terlihat pada gambar 1.1. Semua 

objek seperti gambar, tulisan dan foto ditempatkan pada stage. Di luar area kotak putih tersebut 

merupakan daerah yang berwarna abu-abu. 

 

 
Gambar 1.1 : lingkungan Flash 

 

Toolbox 

Toolbox berisi alat-alat kerja yang  paling sering digunakan dan diwakili berbagai simbol 

gambar atau icon seperti yang terlihat pada gambar 1.1. Setiap simbol gambar atau icon tersebut  

mempunyai fungsi tertentu  

 

Panel 

Panel dalam lingkungan Flash yang terlihat pada gambar 1.1 berfungsi untuk 

menampilkan dan mengubah informasi suatu objek yang ada di stage.Dapat terlihat ada berbagai 

macam papan panel di lingkungan Flash dan setiap panel akan menampilkan informasi tersendiri 

sesuai dengan objek yang dipilih. 

 

 

 

Launcher Bar 

Launcher Bar terdiri atas beberapa icon yang berfungsi untuk menampilkan dan 

menyembunyikan panel info, mixer, instance, frame, actions, movie explorer, dan windows 

library.  
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Movie 

Movie merupakan gabungan semua objek gambar, animasi, tulisan  dan suara dalam 

suatu stage yang telah terbentuk jalan ceritanya. 

 

User 

Istilah untuk mewakili seseorang yang melihat movie atau bisa juga dikatakan penonton. 

 

Timeline 

Semua jalan cerita diatur di timeline, kapan sebuah aktor harus muncul dan kapan 

menghilangnya, atau kapan efek suara harus ada, atau musik latar mengalun, atau kapan 

munculnya suatu objek. Masalah kapan disini adalah masalah waktu. Sehingga Timeline 

mempunyai tugas mengatur waktu cerita dan pemunculan objek-objek tertentu. Komponen utama 

dari timeline adalah layer, frame dan playhead 

 

Frame 

Frame adalah sebuah gambar dari kumpulan banyak gambar. Jika perpindahan frame-

frame dilakukan secara cepat maka akan terlihat seolah-seolah sebuah gambar bergerak. 

 

Layer 

Layer seperti lembaran kertas transparan yang berguna untuk membantu proses animasi 

dan penggambaran. Setiap layer berdiri sendiri-sendiri, penjelasan mengenai layer akan dibahas 

lebih lanjut dalam bab 3. 

 

Framerate 

Framerate adalah ukuran kecepatan frame yang ditampilkan untuk user dalam melihat 

gambar-gambar yang bergerak. Ukurannya dalam frame per detik atau frame per second  yang 

disingkat fps. Framerate 30 fps artinya dalam setiap detik frame yang ditampilkan sebanyak 30 

fps, sehingga setiap detik kita akan melihat 30 gambar yang berbeda. 

1.2. Ilustrasi Movie. 

 Dalam proses nyata pembentukan animasi, rol film yang berisi kumpulan gambar tersebut 

diproses oleh alat yang dinamakan projector untuk ditampilkan satu persatu di layar bioskop.  

 Pada lingkungan flash, konsep tersebut mempunyai kemiripan, yaitu objek yang ada di 

stage dan pengaturan jalan ceritanya melalui timeline akan diproses oleh projector(flash player) 

untuk ditampilkan di beberapa media seperti web, televisi dan cd-rom. 
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Menggambar dan Mewarnai 

 

Pengenalan 

 

Flash memberikan bermacam-macam alat untuk menggambar berbagai macam bentuk  

seperti garis, lingkaran, dan kotak. Dalam lingkungan Flash, tools merupakan kumpulan simbol 

gambar atau icon yang mempunyai fungsi tertentu dalam proses penggambaran di stage. Lihat 

gambar 2.1 

 

        
Gambar 2.1 : Alat gambar di lingkungan Flash 

 

Pada Gambar 2.1, semua fungsi dibagi dalam empat katagori, yaitu : Tools, View, 

Colors, dan Option. Hal ini jelas untuk membantu  Anda dalam memberi pengertian terhadap 

fungsi-fungsi tersebut.  

1. Tools, berisi fungsi-fungsi untuk menggambar, menyeleksi, membuat tulisan, 

mewarnai, menghapus, dan membuat path. 

• Untuk membuat garis atau bentuk seperti Anda menggunakan pensil, 

gunakan Pencil Tool. 

• Untuk menggambar path seperti garis lurus atau melengkung, gunakan Pen 

Tool. 

• Untuk menggambar garis, lingkaran dan kotak, gunakan Line, Oval, dan 

Rectangle Tool 
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• Untuk menggambar menggunakan brush, gunakan Brush Tool 

2. View, berisi fungsi-fungsi untuk membantu kita dalam melihat atau memandang 

gambar. 

• Hand tool untuk menggeser kanvas tersebut 

• Zoom tool untuk memperbesar dan mengecilkan gambar 

3. COLOR, berisi fungsi-fungsi untuk mewarnai. 

• Stroke Color menentukan warna outline pada objek gambar 

• Fill Color berguna untuk mewarnai gambar 

Option, berisi pilihan yang lain untuk memberi variasi pada fungsi-fungsi tools dan view. Jika 

kita mengklik icon zoom tool maka option akan menyediakan dua pilihan, yaitu ingin 

memperbesar atau mengecilkan gambar. 
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Buat lingkaran di stage, kemudian dengan Arrow Tool ,  klik bagian Fill dari shape 

sehingga bagian fill akan terseleksi (ditandai dengan kumpulan titik-titik pada fill).  

 

 

 
 

Sekarang klik bagian stroke dari shape lingkaran tersebut sehingga bagian stroke akan 

terseleksi (ditandai dengan kumpulan titik-titik pada stroke).  

Perhatikan icon Stroke (gambar pensil,  ) dan icon Fill (gambar kaleng cat, 

). Jadi Kalau Anda ingin mengganti warna, lihat dulu jenis shape-nya, apakah stroke 

atau fill.  

 

Maka Kalau kita geser salah satu dengan menggunakan Arraw Tool maka akan kelihatan menjadi 

dua buah object 

 

Free Transform Tool 

Alat ini berfungsi untuk mengubah bentuk suatu objeck, baik itu hal skala, putar, besar, kecil 

ataupun menyamping. Tombol ini sangat membantu terutama pada saat membuat animasi frame 

to frame. Alat ini juga mempunyai 4 macam tombol Bantu yaitu: 

Fill Stroke 

Fill 
Stroke 
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1. Rotate And Skew,  

2. Scale,  

3. Disort, dan  

4. Envelope 

 

Untuk mencoba tool diatas 

Buat sebuah object segi empat pada stage 

Klik tool free transform tool  

Klik objeck yang sudah kita buat tadi 

 

anda bisa mencoba berbagai option yang sudah disediakan pada tool ini 

Rotate And Skew,  

 

Scale,  
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Disort 

 

Envelope 

 

ARROW & SUBSELECTION TOOL  

Kolaborasi antara Arrow Tool (V) dan Subselection Tool (A) untuk menggambar hati. 

Aktifkan Snap to Objects (Ctrl+Shift+/).  
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Symbol adalah salah satu keunggulan dari Flash dalam hal animasi karena dapat mengurangi 

ukuran file dan mempermudah pekerjaan. Anda dapat membuat symbol dari awal atau 

merubah dari objek yang sudah ada ke dalam bentuk symbol.  

Latiahan : 

Buat gambar seperti dibawah 
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PERTEMUAN II 

 

MERUBAH OBJEK MENJADI SYMBOL  

Anda harus membuat sesuatu objek terlebih dahulu di Stage, misalkan lingkaran. Dengan 

panah hitam, seleksi objek yang ingin di jadikan symbol.  

 

 
      menyeleksi objek                                         objek yang sudah terseleksi  

 

Pilih menu Insert > Convert to Symbol … (F8) , maka akan muncul kotak dialog 

Convert to Symbol. Beri Nama “bulatan” dan pilih Behaviour “Graphic”.  

 

 
 

MELIHAT SYMBOL DI LIBRARY  

Semua objek yang telah dirubah menjadi symbol akan tersimpan otomatis di Library. Untuk 

membuka library, klik menu Window > Library (F11).  
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Perhatikan icon dari symbol “graphic”   pada Library. 

Symbol yang ada di library ini dapat digunakan berkali-kali di stage. Anda hanya 

tinggal mengambil dari library dan meletakkannya di stage sebanyak apapun Anda 

mau.  

Symbol yang sudah ada di stage mempunyai nama baru, yaitu  Instance .  

Hebatnya, biarpun di stage ada ratusan symbol yang di ambil dari library. Flash hanya 

menyimpan satu Master Symbol yang ada di library saja. Instance-instance yang ada di 

stage tidak mempengaruhi ukuran file.  
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MEMBUAT SYMBOL BARU  

Sebelumnya kita telah membuat objek yang sudah ada di stage menjadi symbol. Kini 

bagaimana bila ingin membuat symbol baru tanpa membuat objek terlebih dahulu ?  

Pilih menu Insert > New Symbol … (Ctrl+F8) untuk menampilkan kotak dialog Create New 

Symbol. Langsung saja klik tombol OK.  

 

 
 

Anda akan menemukan stage kosong dengan bulatan kosong pada timeline, berarti daerah ini 

belum ada penghuninya, oleh karena itu bisa dimulai gambar apa saja.  
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Setelah di gambar, maka bulatan kosong tadi berubah menjadi hitam pada timeline, yang 

berarti daerah ini sudah diisi oleh penghuni.  Kini dengan panah hitam, klik tulisan Scene 1 di 

samping tulisan Symbol 1 untuk kembali ke stage “Scene1”.  

 

 

 
 

Anda akan melihat stage “Scene1” tidak ada isinya sama sekali (belum ada penghuninya yang 

ditandai dengan bulatan kosong. Symbol 1 yang kita telah buat tadi masih tersimpan dalam 

library dan harus Anda tarik ke Stage “Scene 1” agar bisa dilihat oleh penonton.  
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MERUBAH MASTER SYMBOL   

Bagaimana bila kita ingin mengedit master symbol, misalkan bentuknya kita ingin rubah 

tidak lingkaran, melainkan kotak.  

Untuk merubah master symbol, Anda klik dua kali pada gambar symbol yang ingin di edit 

untuk masuk ke dalam stage “Symbol 1”. Setelah itu baru Anda bisa merubahnya.  

 

 

 
 

Setelah masuk ke dalam stage “Symbol 1”, gantilah gambar lingkaran dengan kotak. Anda 

bisa menghapus terlebih dahulu gambar lingkaran itu baru kemudian menggambar kotak 

seperti yang terlihat pada gambar berikut ini.  
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Klik tuilsan “Scene 1” untuk kembali ke stage “Scene 1”, Anda akan melihat perubahan 

secara otomatis di stage “Scene 1”.  

 

 

 
Merubah master symbol yang ada di library, berarti merubah seluruh instance yang ada di 

stage “Scene 1”. Ini adalah sifat dari symbol !!!  
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MERUBAH INSTANCE  

 

Seperti yang telah kita ketahui sebelumnya, instance adalah symbol yang ada di stage. Setiap 

bisa instance mempunyai posisi, rotasi, skala dan warna yang berbeda. Tetapi Anda tidak bisa 

merubah bentuk instance !!! Kalau sudah kotak, yah kotak saja. Kalau mau berubah bentuk, 

Anda harus merubah master symbolnya, yang berarti merubah seluruh bentuk instance yang 

ada di stage.  

 

 
Klik salah satu instance di stage untuk melihat informasinya di Property Inspector. 
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 ANIMASI 

 

Animasi mempunyai ukuran FPS (Frame per Second). Untuk layar bioskop yang sering 

kita tonton mempunyai ukuran 24 FPS, artinya mata kita melihat 24 gambar (frame) dalam setiap 

detiknya. Bayangkan bila kita menonton selama satu jam, berapa banyak gambar yang telah 

ditembakkan ke mata kita. Tetapi animasi Flash mempunyai ukuran 12 FPS. Oleh karena itu 

sebelum Anda membuat animasi, tentukan dulu berapa lama animasi tersebut akan berjalan. 

 

Animasi Frame by Frame 

 

Saat Anda membuat sesuatu yang baru, kita melihat timeline dengan satu blank keyframe yang 

diwakili dengan gambar bulat kecil yang berwarna putih. Artinya Stage dalam frame tersebut 

tidak berpenghuni.  

Atau arti lain dari blank keyframe adalah seperti Anda mempersiapkan kertas yang kosong. 

Pastikan terdapat simbol blank keyframe di timeline atau  Anda tidak bisa menggambar apapun 

di Stage.  

 

 

 
Sekarang coba gambarkan kotak dengan rectangle tool di Stage.  

 

Artinya setelah titik bulat kosong tersebut 

menjadi berisi (titik hitam), yang menandakan 

bahwa stage telah terisi sesuatu.  

 

 

 

 

 

Keyfram
ae 
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Kemudian kita perlu kertas baru lagi (blank keyframe) untuk menggambar sesuatu yang baru. 

Klik kanan frame k-2 dan pilih Insert Blank Keyframe.  

 

 
 

➢ Kembali stage dalam keadaan kosong. Dan gambarkan objek lingkaran di frame ke-2 ini.  

➢ Setelah itu Anda akan melihat blank keyframe tadi menjadi keyframe yang berisi (titik 

hitam).  

➢ Buat gambar segitiga di Frame ke-3 dengan cara yang sama.  

➢ Kini Anda mempunyai tiga frame yang masing-masing bergambar kotak, bulat dan 

segitiga.  

➢ Pilh menu Control > Play (Enter) untuk melihat bagaimana animasi tersebut berjalan.   

➢ Bila ingin melihat animasi tersebut secara terus menerus dijalankan pilih menu Control > 

Loop Playback. Kemudian kembali tekan Enter.  

➢ Kini Anda akan melihat gerakan animasi tersebut di stage. Stage seperti layar bioskop 

dan timeline seperti alat untuk memproyeksi gambar atau frame secara bergantian ke 

stage.  

 

 

Latihan : 

1. Simulasi Lampu Merah 

2. Bola Mantul. 



 

 

ndaru@stmik-banisaleh.ac.id 

PERTEMUAN III 

 

Motion Tween 

 

Untuk menggerakan animasi berupa obyek yang bergerak, langkah yang tercepat yang bisa 

dilakukan adalah dengan menggunakan Motion Twen. Anda tinggal menetukan posisi pertama 

dan posisi terakhir obyek. Selanjutnya kita tinggal menggerakannya dengan motion tween. 

1. Buatlah gambar lingkaran. 

2. Seleksi gambar dengan Selection Tool. 

3. Aktifkan Selection Tool dan klik pada frame 20. 

 
4. Pilih menu Insert lalu pilih key frame. 

 
5. Pindahkan posisi gambar dari tempat semula kearah kanan. 
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6. Klik kanan diantara Frame 1 dan 20. 

7. Pilih Create Motion Tween 

 
8. Jalankan animasi dengan menekan “Ctrl+Enter”. 

 

Latihan : 

1. Logo Memutar. 

2. Simulasi permainan Bilyar. 
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Motion Mask 

 

1. Siapkan area state dengan ukuran 370 x 85 pixel, dengan frame rate 12 fps. 

2. Buat tulisan di layer 1 – frame 1 dengan tulisan “FLASH MX” di state dengan ukuran 

property , Nama font : Century Gothic, Size = 12 dengan Bold dan Italic, dengan warna 

Biru. 

 

 

 

3. Kemudian jadikan objek tulisan tersebut menjadi symbol graphic dengan registration titik 

tengah 

4. Lalu tambahkan layer 2, kemudian copy kan objek yang ada di layer1 ke layer 2, dengan 

cara : 

a. Klik objek tulisan pada layer 1, lalu tekan ctrl+c 

b. Kemudian klik frame1 pada layer 2, lalu tekan ctrl+shift+c   

5. Lalu tambahkan layer 3, dan tambahkan objek kotak dengan ukuran  15.4 x 118 pixel 

dengan warna putih ke posisi pinggir kanan state. 

6. Kemudian rubah nama layer 1 = Text1, Layer 2 = Text2, Layer3 = Kotak, kemudian atur 

posisi layer seperti gambar dibawah ini : 

  
7. Kemudian atur panjang frame pada masing-masing layer ke frame 30, dengan menklik 

kanan kemudian Insert Keyframe pada posisi frame 30. 

 
8. Kemudian tambahkan keyframe pada frame 10 di layer “Kotak”, lalu pada frame 1 pada 

layer kotak klik kanan -> Create Motion Tween. 
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9. Kemudian klik frame 10 geser objek kotak tersebut kepinggir kiri state. 

 

 

 

 

 

 

 

 

10. Kemudian pada layer ‘Text1’, klik kanan -> Mask. 

11. Jalankan dengan tombol Crtl+Enter 
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PERTEMUAN IV 

 

MOTION GUIDE 

1. Buat lingkaran seperti pada gambar di bawah ini 

 

2. Tambahkan layer motion guid dengan cara: 

a. Pada menu insert pilih Motion Guid atau 

b. Klik kanan pada layer pilih Add Motion Guid 

3. Pada layer Motion Guid, Buat Lingkaran lagi dengan ukuran lebih besar, hapus 

fill-nya sehingga yang tampak hanya stroke-nya. 

4. Dengan menggunakan Arraw Tool hapus sebagian lingkaran (stroke), sehingga 

ada ujing dan akhir. 

 

5. Tambahkan lebar keyframe pada masing-masing layer sampai frame 20, dengan 

mengklik kanan pada frame 20 lalu Insert Keyframe.  
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6. Blok frame 1 sampai 10, klik kanan pilih Create Motion Tween. 

 

7. kemudian klik frame 1, kemudian rubah posisi objek lingkaran1 ke titik pertama 

pada objek oval dan klik frame 20  rubah posisi objek lingkaran 1 ke titik ke dua di objek 

oval. 

 

 

 

 

8. Kemudian jalankan animasi tersebut dengan menekan tombol Ctrl+Enter  

Catatan: 

Untuk membuat guid bisa pake apa saja yang penting berupa stroke ada ujung dan akhir jangan 

terputus-putus. 

Latihan 1: 

1. Buat animasi tatasurya. 

2. Kereta Api. 

3. Simulasi jalan mudik. 

 

 

 

Lingkaran1 

Lingkaran2 

Lingkaran3 

Posisi lingkaran1 di frame 1 Posisi lingkaran1 di frame 1 
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MOVIE CLIP  

Sebelumnya kita telah mengenal bahwa symbol mempunyai tiga (3) sifat, yaitu graphic, movie 

clip dan button. Kita sudah mempelajari symbol graphic yang mempunyai sifat statis atau 

diam. Kini kita akan mengenal movie clip yang mempunyai sifat bergerak.   

 

 
1. Buat symbol baru dengan memilih menu Insert > New Symbol… F8 , dan beri nama 

“bola_bergerak” dengan sifat “movie clip”.  

 
 

2. Seperti biasa, Anda akan menemukan halaman kosong  setiap kali membuat symbol 

baru. Anda kini berada pada stage movie clip “bola bergerak”.  
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3. Kemudian tarik symbol graphic “bola” ke dalam stage ini.  

4. Movie clip mempunyai gambar simbol berbeda dengan symbol graphic kalau Anda 

perhatikan di library. Di stage ini, kita akan membuat bola ini berputar.  

 

1. Pertama-tama tentukan dulu berapa panjang frame animasi ini, misalkan 15 frame. Dan 

kita masih akan menggunakan teknik animasi motion tweening. Syarat pertama sudah 

terpenuhi bahwa gambar bola sudah berupa symbol.  

2. Setelah itu syarat kedua, minimal animasi harus mempunyai dua (2) keyframe, oleh 

karena itu Insert Keyframe di frame ke-15.  

3. Klik di antara dua keyframe tersebut, pilih animasi Motion di Properties dan klik Rotate : 

CW, 1 times.  (Lihat tanda bulatan di Atas). Ini berarti bola akan berputar sesuai arah 

jarum jam (CW) sebanyak 1 kali. Ini adalah syarat ketiga (Rotation).  

4. Setelah itu balik ke Scene 1 dan kita akan menemukan gambar bola, tetapi dengan sifat 

graphic. Anda bisa mengambil movie clip “bola bergerak” dan meletakkannya di stage 

sebanyak apapun. Kemudian Coba jalankan. Perhatikan ada bola yang bergerak dan 

ada yang tidak.   
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5. Inilah perbedaan antara symbol dengan sifat graphic dan movie clip. Untuk diingat 

kembali bahwa Anda harus tahu dari mana symbol tersebut berasal sehingga sewaktu-

waktu kita ingin merubah bentuknya akan tahu tempat yang benar.  

Dalam kasus ini, symbol movie clip “bola bergerak” berasal dari symbol graphic “bola”. Oleh 

karena itu bila Anda ingin merubah bentuk bolanya, Anda harus masuk ke dalam stage symbol 

graphic “bola”. Hal ini berguna mengetahui dari mana symbol tersebut berasal atau terbentuk bila 

Animasi tersebut sudah melibatkan begitu banyak symbol dalam symbol dalam symbol dalam 

symbol… kedalamannya bisa tidak terbatas ! 
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1. Mengenal Panel Action Script 

 

Panel Action adalah tempat untuk menulis perintah atau Script yang dilengkapi oleh bebagai 

fasilitas dan kecanggihan khusus. 

 

Panel ini dibagi dalam beberapa bagian: 

 

1. Informasi Lokasi, yaitu informasi dimana Script diletakan. Frame, Button dan Movieclip 

adalah tempat bersemayamnya script-script tersebut.ketiga tempat tersebut mempunyai 

sifat dan efek yang berbeda dalam memperlakukan script. 

2. Kategori, yaitu daftar script fungsi yang disusun rapi berdasarkan kategori. 

3. Tempat Jelajah, yaitu tempat untuk mengetahui, dan mencari script-script diletakan. 

4. Tempat Mengetik, yaitu tempat untuk menulis perintah atau script. 

 

 
 

Gambar 1.1 Bagian-bagian Panel Action 

 

2. Menampilkan Panel Action  

Untuk menampilkan Panel Action seperti yang terlihat pada gambar 1.1 caranya adalah :  

1. Pilih dan tentukan tempat (lihat gambar 2.1) di mana Anda ingin meletakkan script. 

Apakah itu di :  

 a.  Frame  

b. Button   

c. Movieclip.  

2. Klik dengan mouse tempat tersebut.   

Kalau tempat tersebut terpilih, pasti komputer akan memberi tanda seleksi blok hitam, bila 

Anda memilih di Frame. Dan tanda seleksi kotak berwarna biru bila Anda memilih Button 

atau Movieclip.  

3. Setelah itu tekan tombol F9. Maka Panel Action seperti yang terlihat pada gambar 1.1 akan 

muncul.  
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Gambar 2.1 Target tempat untuk meletakkan script 

 

Pada gambar di atas terlihat bahwa gambar tombol sedang diseleksi, sehingga papan catat yang 

bernama Property Inspector menginformasikan gambar tersebut tersebut adalah symbol “Button” 

(Lihat lingkaran pada gambar 2.1).    

3. Mengatur Panel Action  

Kadang Panel Action seperti menempel di atas papan catat Property Inspector. Anda bisa 

mengeluarkannya dengan menarik “Jerawat” Panel Action keluar. Yah… setiap panel ada 

“jerawat”-nya untuk memindah-mindahkan kotak panel ke tempat tertentu. Lihat gambar 3.1, 

Anda bisa tarik setelah kursor berubah menjadi tanda “+”.  
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Gambar 3.1 Menarik Panel Action keluar 

 

Setelah di tarik keluar, Panel Action akan seperti melayang (tidak menempel) . Tetapi kadang 

Anda tidak berhasil menarik keluar atau bahkan malah menempel di tempat lain. Flash memang 

sensifif, gerakan Anda harus terlatih. Kemudian kadang bagian kategori dan tempat jelajah di 

Panel Action bisa hilang (sembunyi). Oleh karena itu Anda bisa menampilkan dan 

menyembunyikan dengan dua cara, yaitu : a. Menarik batas antara bagian kiri dan kanan. Setelah 

kursor berubah tanda (lihat gambar 3.2), maka  

Anda bisa memulai menarik ke kanan. b. Dengan menekan (klik) tombol mouse di tanda 

(lihat gambar 3.2) yang melekat pada batas antara bagian kiri dan kanan.  
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Gambar 3.2 Menampilkan dan menyembunyikan bagian kategori dan tempat jelajah di Panel 

Action   

 

 

4. Syntax Coloring  

Saat mengetik script (lihat gambar 4.1), pasti kita akan menemukan perbedaan warna antar kata 

yang satu dengan kata yang lain. Warna-warna tersebut mempunyai arti untuk memudahkan kita 

mengenali perintah atau untuk melihat apakah ada pengetikan yang salah.  

 

 
 

Gambar 4.1 Contoh Script 

 

Untuk melihat atau mengganti arti dari warna tersebut, kini buka kota Preferences.  

1. Pilih menu Edit > Preferences … (Ctrl+U)  

2. Klik bagian (TAB) ActionScript  
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Kemudian Anda akan menemukan bagian Syntax coloring seperti gambar 4.2. Kata syntax berarti 

tata bahasa atau grammer. Pengetikan script harus mengikuti aturan (syntax) yang telah 

ditentukan untuk menghindari terjadinya kesalahan yang tidak diinginkan.  

 

 
 

Gambar 4.2 Kotak Preferences – Syntax coloring 

 

Perhatikan juga gambar 4.1 untuk mengikuti arti dari warna-warna berikut ini yang ada pada 

kotak preferences  :  

1. Foreground (Hitam) : Warna tulisan script secara umum. Contoh: i=i+1 (lihat gambar 

4.1).  

2. Background (Putih) : Warna latar tempat mengetik script.  

3. Keywords (Merah) : Warna kata kunci yang telah dicadangkan oleh Flash. Contoh: 

onClipEvent  

4. Comments (Abu-abu) : Warna komentar. Contoh: // Ini adalah komentar.  

5. Identifiers (Biru Tua) : Warna fungsi yang ada di dalam Flash. Contoh: enterFrame, trace.  

6. Strings (Biru) : Warna tulisan berjenis huruf atau kalimat (string). Contoh : “Hello Baba”.  

Jadi dengan panduan warna-warna tersebut, Anda setidaknya bisa lebih berhati-hati bila terjadi 

salah ketik. Karena komputer tidak mengenal kompromi kalau kurang atau kelebihan satu huruf 

saja maka jalannya program akan salah (ERROR).  

 

5. Script di Frame  

Script yang diletakkan di frame disebut Framescript. Untuk meletakkan script di frame adalah :  

1. Tentukan frame berapa yang ingin diberi script. Misalkan frame 10.  

2. Peletakan harus di Keyframe. Kalau di frame 10 belum ada keyframe, Anda harus 

membuatnya dulu dengan menekan tombol F6 (Insert Keyframe).  

3. Setelah itu baru tekan tombol F9 untuk menampilkan Panel Action.  

Pastikan informasi lokasi di Panel Action menunjukkan tulisan “Frame” untuk menghindari 

kesalahan lebih lanjut. Karena sering kali terjadi mereka yang tidak teliti akan menekan mouse di 

sembarang tempat (bukan di Frame). Setelah itu baru Anda bisa bebas mengetik script.  
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Gambar 5.1 Informasi lokasi framescript 

 

Bila telah selesai mengetik script, tutup Panel Action. Anda akan menemukan tanda “a” di frame 

(keyframe) yang telah diletakkan script (lihat gambar 5.2). Suatu waktu bila ingin merubah script 

tersebut, klik tanda “a” di frame (keyframe) dan tekan tombol .  

 

 
Gambar 5.2 Actionscript di Frame (Keyframe) 

 

Layer tidak ada hubungannya dengan script. Script di Frame 10, diletakkan di layer manapun 

tidak masalah. Tetapi untuk menjaga kerapian dan kemudahan, sebaiknya Anda meletakkan 

framescript dalam satu layer, misalkan layer “Actionscript”. Bayangkan kalau script-script Anda 

(gambar 5.2) terpencar di banyak layer. Pasti kita akan kebingungan dalam pencarian nantinya. 

Hal-hal kecil ini bila tidak terorganisir dengan baik akan membuat Anda stress dan membuat 

pekerjaan menjadi lama.  

6. Event di Frame  

Setiap perintah atau script yang diketik tentunya harus ada pemicu. Misalkan manusia sudah 

diberi perintah (emosi) marah. Perintah atau kejadian tersebut harus ada pemicunya, yaitu kalau 

ditampar pipinya, maka kejadian marah akan dijalankan. Pemicu ini disebut Event (kejadian) di 

Flash. Setelah Anda mengetik script di frame 10 tadi, pemicunya adalah ketika playhead (lihat 

gambar 6.1) telah mencapai frame 10. Kalau playhead belum mencapai frame 10, misalkan masih 

di frame 8, perintah di frame 10 tidak akan dijalankan. Frame hanya mempunyai satu event saja 

dan hanya dijalankan sekali (bukan berkali-kali).   

 

 
 

Gambar 6.1 Playhead sebagai pemicu(Event) 

 

Kalau Anda meletakkan perintah marah di frame 10.  Maka perintah marah tersebut hanya 

dijalankan sekali saja walaupun playhead berhenti di frame 10. Inilah salah satu sifat script yang 

diletakkan di frame. Bagaimana kalau perintah mau dijalankan berkali-kali? Anda harus 

menyuruh playhead kembali berjalan dari frame sebelumnya, misalkan frame 8 atau frame 9. 

Setelah itu playhead kembali melewati lagi frame 10, perintah akan dijalankan kembali dan 

begitu seterusnya.  

7. Enable Simple Frame Actions  
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Setelah mengenal sebagian daerah kekuasaan di Panel Action. Mari sekarang kita mulai mengetik 

script.   

1. Pilih menu File > New... (Ctrl+N) untuk memulai file baru.  

2. Buat keyframe di frame 10  

3. Klik keyframe 10 tersebut karena kita akan mengetik script di sana.  

4. Tekan tombol F9 untuk menampilkan Panel Action.  

5. Ketik di Panel Action script :  gotoAndPlay(3);  

 

 
 

Gambar 7.1 Melihat jalannya Script 

 

6. Tutup kembali Panel Action  

7. Pilih menu Control > Enable Simple Frame Actions  

8. Jalankan movie flash tersebut dengan menekan tombol ENTER.  

Maka Anda akan melihat playhead akan terus berjalan berulangkali (looping) karena ada perintah 

di frame 10 untuk menyuruh playhead balik lagi ke frame 3 dan begitu seterusnya. Mengapa 

harus mengaktifkan Enable Simple Frame Actions? Hal tersebut untuk melihat jalannya script. 

Coba Anda menonaktifkan fasilitas tersebut dengan memilih kembali Enable Simple Frame 

Action dan kemudian menekan tombol ENTER. Pasti script tersebut tidak akan berjalan. Fasilitas 

ini sangat berguna untuk menunjukkan kepada pemula bagaimana cara kerja script di Frame. 

Lebih tepat  lagi sebagai sarana ajar saja bagi siswa. Karena tentu sulit menunjukkan kepada 

orang jalannya playhead bila sudah jadi movie Flash.  

 

Sesuai dengan namanya Enable Simple Frame Actions. Berarti hanya script-script dasar saja 

seperti gotoAndPlay(), gotoAndStop(), Stop() dan Play() yang bisa berjalan. Untuk script yang 

lebih rumit, Anda harus menjalankannya dengan cara lain.  

8. Script di Button (Tombol)  

Script yang diletakkan di button (tombol) disebut Buttonscript. Untuk meletakkan script di 

tombol adalah :  

1. Pastikan tombol yang dimaksud sudah terpilih (diklik). Perhatikan juga informasi 

(gambar 8.1) di Property Inspector apakah benar tombol tersebut yang dimaksud.  

2. Setelah semuanya dipastikan, tekan F9 untuk menampilkan Panel Action.  

 

 



 

 

ndaru@stmik-banisaleh.ac.id 

 
 

Gambar 8.1 Informasi tombol di Property Inspector 

 

Pastikan informasi lokasi di Panel Action menunjukkan tulisan “Button” (Gambar 8.2) untuk 

menghindari kesalahan lebih lanjut. Flash sangat rentan atau sensitif kalau sudah masuk ke dalam 

Actionscript karena banyak jalan menuju ERROR (kesalahan). Tetapi jangan takut, kalau Anda 

sudah terbiasa, hal-hal yang telah disebutkan di atas jarang sekali terjadi dan kalaupun terjadi 

akan sangat gampang terdeteksinya.  

 

 
Gambar 8.2 Informasi lokasi Buttonscript 

Baru setelah melewati berbagai pengecekan dan rintangan di atas, Anda bisa bebas mengetik 

script.  

9. Event di Button  

Script di tombol-pun harus ada pemicu. Kalau di frame hanya mempunyai satu pemicu, di tombol 

punya banyak sekali pemicu/kejadian (event), antara lain :    press: kejadian saat tombol mouse 

ditekan.    release: kejadian saat tombol mouse ditekan dan kemudian dilepas.  

 

 

   releaseOutside: kejadian saat tombol mouse ditekan dan kemudian dilepas di luar area 

objek tombol.    rollOver: kejadian saat kursor mouse masuk dalam area objek tombol. Pada 

saat ini tombol mouse belum ditekan.    rollOut: kejadian saat kursor mouse masuk dan 

kemudian keluar dari area objek tombol. Pada saat ini tombol mouse belum ditekan.    

dragOver: kejadian saat tombol mouse ditekan dan kemudian keluar dari area tombol. Pada 

saat ini tombol mouse masih ditekan, belum dilepas.    dragOut: kejadian saat tombol mouse 
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ditekan dan kemudian keluar dari area tombol dan kemudian masuk lagi ke dalam area 

tombol. Pada saat ini tombol mouse masih ditekan, belum dilepas.  

10. Syntax di Button  

Untuk mengetik script di tombol, Anda harus tahu tata bahasa atau syntax agar perintah dapat 

berjalan dengan benar. Di bawah ini adalah syntax untuk buttonscript.  

on ( nama_event ) 

{  perintah atau handler }  

Nama event anda bisa lihat di trik sebelumnya tentang Event di Button.  

Jadi jelas sekali perbedaan antara framescript dan buttonscript. Framescript hanya punya satu 

event, jadi Anda bisa langsung mengetik perintah. Sedangkan Buttonscript punya banyak sekali 

event, sehingga Anda harus mengetik nama eventnya dulu dan baru kemudian mengetik perintah.  

11. Teknik cepat menampilan Event di Button  

Tentu Anda kadang lupa nama-nama event di tombol. Jangan khawatir, ini ada teknik cepat untuk 

menampilkan nama event tersebut.  

1. Masuk ke dalam Panel Action, pastikan informasi lokasinya “Button”.  

2. Saat Anda mengetik  on(  , maka nama-nama event tombol akan tampil dengan 

sendirinya (Gambar 11.1). Yang penting Anda ingat saja kalau ingin mengetik script di tombol, 

hafalkan saja harus dimulai dengan tulisan on( . Selanjutnya lihat syntax selengkapnya, jangan 

sampai salah ketik atau lupa. Ada 2 tanda buka dan tutup kurung di situ.  

 

 

 
Gambar 11.1 Informasi lokasi Buttonscript 

 

12. Common Library  

Common Library berisi berbagai macam tombol, aplikasi dan program siap pakai. Untuk 

membuka Common Library.  

1. Pilih menu Window > Other Panels > Common Libraries  

2. Ada tiga (3) pilihan Buttons, Classes, Learning Interaction.  

3. Pilih saja Buttons, karena kita akan menggunakan tombol yang sudah siap (Gambar 12.1) 

pakai sebagai latihan kita berikutnya. Di sana tombol dibagi dalam berbagai folder atau kategori. 

Buka saja salah satu folder dan pilih jenis tombol yang ingin Anda gunakan.  
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Gambar 12.1 Common Libraries - Buttons 

 

13. Enable Simple Buttons  

Sekarang mari kita menguji coba script yang diletakkan di tombol.   

1. Pilih menu File > New... (Ctrl+N) untuk memulai file baru.  

2. Ambil tombol di folder Arcade buttons > arcade button – orange, dan masukkan ke 

dalam Stage.  

3. Panjangkan frame sampai frame 15. Klik frame 15 dan tekan F5 (Insert Frame).  

4. Kemudian ketik script berikut ini. (Gambar 13.1)  

 

 
Gambar 13.1 Buttonscript 

 

5. Tutup kembali Panel Action  

6. Pilih menu Control > Enable Simple Buttons (Ctrl+Alt+B).  

7. Sekarang tekan tombol di Stage dan playhead akan lompat ke frame 10.  
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Kalau diperhatikan saat Anda masuk dalam area objek tombol, kursor mouse akan otomatis 

berubah menjadi gambar jari. Saat keluar dari objek tombol, kursor mouse kembali lagi menjadi 

bentuk panah. Ini akan memudahkan user (pengguna) untuk tahu objek mana yang bisa diklik dan 

mana yang tidak. Mengapa harus mengaktifkan Enable Simple Buttons? Seperti yang telah 

dijelaskan sebelumnya, hal ini untuk memudahkan kita belajar melihat jalannya script. Dan hanya 

script-script dasar saja yang bisa digunakan. Untuk merubah atau mengedit script di tombol. 

Anda harus kembali menonaktifkan fasilitas Enable Simple Buttons.  

 

14. Memilih perintah dari bagian kategori Panel Actions  

Untuk memilih perintah gotoAndPlay(), Anda bisa tidak perlu mengetik. Lihat saja pada bagian 

kategori panel action dan pilih perintah yang diinginkan. Langkah-langkahnya adalah :  

1. Perintah gotoAndPlay() ada di bagian kategori Global Functions > Timeline Control > 

gotoAndPlay [Esc-gpp].  

2. Klik saja tulisan gotoAndPlay, maka script akan ditambahkan di bagian pengetikan script 

(sebelah kanan).  

 
Gambar 14.1 Script dari Kategori Panel Actions 

 

Kalau diperhatikan ada tanda [Esc-gp]. Itu adalah shortcut atau jalan yang lebih singkat lagi 

untuk menulis script. Tekan saja tombol Esc ditambah huruf g dan p bersama-sama, maka 

perintah gotoAndPlay(); akan tampil di tempat pengetikan script. Setelah itu Anda tinggal 

mengisi nomor frame yang diinginkan. Syarat pengetikan dengan cara ini tentunya Anda harus 

hafal tempat dan shortcut script tersebut. Tetapi kalau sering digunakan, biasanya kita sudah 

otomatis tanpa bersusahpayah lagi menghafal.  

 

 

15. Frame Label  

Anda bisa memberi nama atau label kepada frame untuk memudahkan dalam membaca Timeline. 

Caranya :  

1. Pilih nomor frame yang ingin diberi label. Misalkan frame 1. Label hanya bisa diisi pada 

Keyframe. Bila dalam suatu frame belum ada keyframe. Tambahkan keyframe dengan 

menekan tombol F6 (Insert Keyframe).  

2. Klik frame tersebut dan ketikkan nama label di papan catat Property Inspector (Gambar 

15.1).  

Pada gambar 15.1 terlihat pada Layer 2, kalau framenya panjang, label “Baba” akan terlihat. 

Sedangkan di Layer 1, framenya pendek sekali sehingga frame diberi label tidak terlihat. Tetapi 

ini hanya pengaruh pada pandangan mata saja, frame tersebut tetap mempunyai label. 

Penggunaan frame label ini akan berguna saat kita menggunakan fungsi-fungsi navigasi.  
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Gambar 15.1 Frame Label 

 

16. Fungsi-fungsi Navigasi  

Fungsi stop(),tujuannya untuk memberhentikan movie Flash pada frame yang diberi 

script ini. Fungsi play(),tujuannya untuk menjalankan movie Flash pada frame yang 

diberi script ini.  

 

Fungsi gotoAndStop([scene,] frame), tujuannya untuk lompat dan berhenti ke nomor frame atau 

frame label tertentu. Contoh  

gotoAndStop(“Baba”)

; gotoAndStop(10);  

 Fungsi gotoAndPlay([scene,] frame), tujuannya untuk lompat ke nomor frame atau frame label 

tertentu dan kemudian tetap berjalan. Contoh  

gotoAndPlay(“Baba”)

; gotoAndPlay(10);  

Anda harus hati-hati dalam mengetik script, huruf besar dan kecil dibedakan oleh Flash, lihat 

syntax yang telah diberikan. Oleh karena itu ingat panduan warna script yang telah dibahas pada 

bab sebelumnya.  

 

17. Komentar  

Script merupakan bahasa komputer yang sulit dibaca untuk mereka para pemula. Oleh karena itu, 

kita bisa memberinya komentar di tengah-tengah perintah.   

 

Cara ke-1 adalah :  

// Perintah untuk berhenti pada frame tertentu 

gotoAndStop(10);  

Atau dengan cara ke-2  

/*   

 

 

Perintah untuk pergi ke frame tertentu 

Dan kemudian tetap dijalankan  */ 

gotoAndPlay(10);  
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Cara ke-1 dengan tanda “//” untuk memberi komentar per baris. Dan cara ke-2 dengan dimulai 

tanda “/*” dan diakhiri tanda “*/”untuk memberi komentar lebih dari satu baris. Tulisan komentar 

akan berwarna abu-abu.  

18. Navigasi yang efektif dan efisien  

Navigasi berfungsi agar pengguna dapat berinteraksi dengan movie flash yang kita buat. 

Misalkan mereka ingin pergi ke bagian tertentu, kita sebagai pembuat telah menyediakan navigasi 

yang berupa tombol untuk mereka klik. Untuk membuat navigasi yang efektif dan efisien dalam 

pembuatan sebuah situs maka perlu adanya pengorganisasian yang baik. Berikut adalah hal-hal 

yang perlu diperhatikan (Gambar 18.1):  

1. Setiap nama layer dan nama symnbol harus diberi nama sesuai dengan fungsinya.  

2. Begitu juga dengan framelabel, walaupun bisa diletakkan di layer terpisah. Sebaiknya 

ditempatkan di dalam satu layer seperti yang terlihat pada gambar.  

3. Kalau ada script di frame, sebaiknya juga dijadikan dalam satu layer, misalkan layer 

framescript.  

 

 
 

Gambar 18.1 Timeline yang terorganisir 

 

19. Membuat Navigasi Sederhana  

Jalan ceritanya begini…   

1. Ada tiga (3) tombol di Stage yang diletakkan dalam satu (1) layer “Button”.  

2. Ketika diklik salah satu tombol, maka di Stage akan menampilkan animasi isi (content) 

yang berbeda.  
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Gambar 19.1 Navigasi Sederhana 

 

Caranya begini… (Sambil lihat gambar 1.19)  

1. Buat layer “Frame Label”, beri nama label “satu” di frame 1, label “dua” di frame 10 dan 

label “tiga” di frame 20. Panjangkan sampai frame 30.  

2. Buat layer “Frame Script”, beri framescript stop() di frame 9, 19 dan 30.  

3. Buat layer “Button”, dan letakkan tiga (3) tombol seperti yang terlihat pada gambar.   

4. Beri script pada tombol ke-1 ( atas )  

on(release){  gotoAndPla

y("satu"); }  

tombol ke-2 ( tengah )  

on(release){ gotoAndPlay

("dua"); }  

tombol ke-3 ( bawa )  

on(release){    

 gotoAndPlay("tiga"); 

}  

5. Buat layer “Content”.  

6. Ketik tulisan “Content 1” dengan menggunakan Text Tool, kemudian jadikan symbol. 

Buat animasi Fade-In [ Tulisan dari tidak ada (Alpha:0) menjadi ada (Alpha:100) ] dari 

frame 1 sampai 9.  

7. Ketik tulisan “Content 2” dengan menggunakan Text Tool, kemudian jadikan symbol. 

Buat animasi FadeIn dari frame 10 sampai 19.  

8. Ketik tulisan “Content 3” dengan menggunakan Text Tool, kemudian jadikan symbol. 

Buat animasi FadeIn dari frame 20 sampai 30.  

9. Aktifkan Enable Simple Buttons dan  Enable Simple Frame Actions untuk melihat 

jalannya program. Jadi saat Anda menekan tombol ke-1, maka perintah lompat ke frame label 

“satu” dijalankan, kemudian playhead berjalan dari frame 1 sampai frame 9 menampilkan 

animasi Fade-In tulisan “Content 1”. Begitu juga yang terjadi pada tombol ke-2 dan ke-3.  
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Menggambar Dengan Action Script 

 

Draw Methods adalah kumpulan fungsi-fungsi dari Action Script untuk menggambar dan 

mewarnai. 

 

Sekarang kita coba beberapa cara untuk menggambar dengan menggunakan Action Srcipt. 

Pertama buat file baru, pada frame1 ketikan framescript di bawah ini: 

 

_root.createEmptyMovieClip("triangle",1); 

with (_root.triangle){ 

 beginfill (0x0000ff, 50); 

 linestyle (2, 0xff00ff, 100); 

 moveto (0, -100); 

 lineto(100,100); 

 lineto(-100,100); 

 lineto(0,-100); 

 endfill(); 

  

} 


